Press enter to see results or esc to cancel.

Can Old iPhones Like iPhone 4/3GS Get iOS 8 Update?

Last updated: September 18, 2014 at 15:45 pm

ios8-on-old-iphones

If your friends or relatives accidentally finds out that you have a decent knowledge in computers and Internet, they are going to ask your help for almost anything. They assume you are an expert in this subject, even though it might not be true. Such was the case recently, when the news of iOS 8 update was out.

The first question was obvious: is it free to download iOS 8?

I answered my cousin: “Yes! Apple iOS 8 is absolutely free.”

This answer led to another question. It wasn’t a question, but more of a demand to install iOS 8 on her iPhone 4 device: “I need it! Put the iOS 8 update on my iPhone 4 now, OK?”

It is important to note that iOS 8 works on only certain Apple devices. You cannot update any iPhone, iPad, or iPod Touch to iOS 8 firmware. What you really need is a compatible device and…

iPhone 3GS and iPhone 4 Are Not Compatible With iOS 8 Firmware

As much as it hurts to say this, none of the old iPhone models can run iOS 8 firmware. We have already mentioned this in our guide: Which iPhones supports iOS 8?

You will see in that guide that only iPhone 4s and later devices can get iOS 8 update.

iPhone 3GS and iPhone 4 users cannot install iOS 8 update.

No OTA. No iTunes update. Nothing.

List of iPhones that cannot install iOS 8:

  • iPhone 2G (2007 model)
  • iPhone 3G (2008 model)
  • iPhone 3GS (2009 model)
  • iPhone 4 (20010 model)

If you own any of these old devices, you are out of luck. Just like my cousin. You have to live with iOS 6 or iOS 7 firmware. And that’s the brutal truth.

Force iOS 8 Update on Old iPhones

Now that we know iOS 8 cannot be installed on old iPhones like iPhone 3GS/4, our next task is to wait for something magical to happen.

And yes, magics do happen in this iOS land.

If you remember, iOS 6 does not work on old iPhone 3G/2G and iPod Touches. A bunch of talented coders solved this problem by introducing custom firmware. Here, you have to download a customized firmware on your computer and install it via Apple iTunes.

This solution called “Whited00r” helps you to get iOS 7, iOS 6, iOS 5 on older iPhone models.

Right now, it does not support iOS 8 firmware yet.

But this gives many of the iPhone users a ray of hope that one day they can access iOS 8 on their devices.

That day, hopefully, will not be very far.

Update x1: Please do not download iOS 8 IPSW files for older iPhone models. In reality, IPSW file for iPhone 3GS/4s does not really exist. We hope that none of you will try to install a different IPSW file on your old iPhones.

Note: Articles written at iOS8release.com are valid for every Apple device running iOS 8.0, iOS 8.1, iOS 8.2, iOS 8.3, iOS 8.4 / 8.4.1 firmware
  • Emma Kirk

    It’s a shame about iOS 7 & iOS 8 – but I’ll have to live with the fact that my 3GS phone (a model from 2009) is no longer compatible for apps below version 6.1.1.6.

    Hopefully newer iPhones won’t be capped or limited – like below iphone 4 has today in 2014 !!!

  • Anonymous_WV

    So … AT&T is going to force iPhone 3GS users to upgrade their phones … my phone won’t allow me to use my AT&T phone app “to pay my bill” without updating to IOS 8. How unfair. NICE ONE, AT&T!

  • garland coleman

    just upgrade you out of date people. WTH is this?
    times change , as should you